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ENGINE MANAGEMENT
Quick Setup Guide
Hardware Quick Setup
1) Remove OE ECU, you’ll need a 10mm socket to remove the harness from the ecu.

2) Connect supplied hose to manifold pressure source.  This pressure tap must be connected to a post throttle body pressure source (it must see both vacuum and boost). The vacuum tree or intake manifold are the best sources for manifold pressure.  Route the supplied hose to the factory ECU location. The easiest way is to poke a small hole in the rubber surrounding the wiring harness where it runs through the passenger side firewall to the ECU.
3) Prior to installing PIMP ECU, install the required internal jumpers for the application.  See Appendix A for jumper functions.  Only install jumpers required for engine operation at this time (ignition pull up, injector jumper, and cooling fan if required). Only a single setup requires no jumpers be installed (4 cylinder with low impedance injectors and CDI ignition box installed non TFI).

4) Plug the factory ECU harness connector into the PIMP ECU.  Connect the supplied hose to the MAP sensor port, and secure with supplied zip tie (used as a hose clamp).
5) Install the new PIMP ECU in the factory hanger, plug in tuning cable, secure PiMP with factory ecu hanger screw.

6) Remove factory air meter/airbox assembly (VAM) and install a cone filter in its place. This is not necessary on speed density 5.0 cars.

7) If originally equipped with a P series ECU (83-86 Turbo Coupe, Mustang, any year XR4Ti), it is recommend an air charge temp (ACT) sensor be installed.  See Appendix B for installation of air charge temp sensor using factory VAM electrical plug.  It should be noted that the MS community will refer to this sensor as an IAT (intake air temperature) sensor.

Wideband Hardware Setup

While not completely necessary, it is HIGHLY recommended a wideband lambda sensor and controller is installed and connected.  It is true skilled (or lucky) individuals tuned engines for decades just fine without them, but many of us do not possess this skill.  

The oxygen sensor input of your new ECU is connected to the factory EEC O2 sensor pin (pin 29).  You have two options to connect your wideband sensor to this pin:

1) If you do not already own a wideband sensor, the AEM 30-2310 lambda cable is recommended.  This sensor and controller can be installed completely under the hood, and an adapter harness can be made by cutting the pigtail off an old factory O2 sensor.  Power, power ground, and the signal to the ECU can be obtained at this connector.  Connect the AEM analog ground to clean under-hood sheetmetal.   Refer to AEM instructions for installation specifics and troubleshooting
2) If you already own a wideband, it can simply be connected to Pin 29 at the ECU.  Clip this wire approximately 6” from the ECU (allowing enough cable to return to stock later if desired), and connect this 6” pigtail coming from the ECU to the analog signal cable of your wideband.  Crimp or solder this connection.  Refer to wideband manufacturers instructions for installation specifics and troubleshooting.
USB Adapter Setup (if you don’t have a Serial port on your laptop)
If you are using a USB-Serial Adapter cable (blue ends with a silver braided cable) then ensure you have installed the proper drivers before plugging in the cable for the first time. Follow the driver installation instructions found on your provided USB Thumb Drive. Open the USB Adapter Drivers folder and then double click the file: USB to Serial Adapter Driver Instructions.doc 
Once the USB Adapter cable drivers are installed and working with no errors, proceed to the TunerStudio Configuration below. 

If your laptop doesn’t have a serial port and you need an adapter cable, we suggest this one: http://www.tigerdirect.com/applications/SearchTools/item-details.asp?EdpNo=1086963&CatId=464
TunerStudio Configuration

The TunerStudio tuning software needs to be properly configured for your setup before usage. Start by installing TunerStudio using the installation file on the USB thumb drive. Once installed, open TunerStudio and follow the instructions below.

1) Open a new project (File > Project > New Project).
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2) Name the project and select “Other” as the ECU Definition. Then click the button highlighted with the red dot below to load the correct definition file from the ms2extra_release folder on the USB drive. Click Next.
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3) Now select the type of wideband sensor you are using and then make sure the settings match the figure below. Click Next.
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4) Select the COM port on your laptop the tuning cable is connected to. If using a USB Adapter cable, this is where you’ll enter the COM number you chose during USB Adapter driver installation. Once installed click “Test Port” to verify the adapter is properly configured. It will say “Successful!” when the laptop is communicating with the PiMP. If it says “Failed!” then select a different COM number and test again. If you are using a USB adapter and get a “Failed!” test after trying COM1-COM10 then you’ll need to revert back to the USB installation instructions after TunerStudio configuration is complete. To finish TunerStudio configuration (even if your adapter isn’t working properly yet), click next. You can revise the port settings once you install your adapter driver by going to (Communications > Settings) in TunerStudio and re-test until you get a successful result. 
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5) Select your Dashboard type. I’d advise using the default dashboard shown below initially. Click Finish. Note that if you wish to display different gauges later, you can right click on any gauge and select a new gauge (change pulse width 2 to coolant temp for example).
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6) You’ll get a warning that the signatures do not match and it will ask if you want to load it anyway. Click Yes. It will ask if you want to view the warnings, click No.
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7) TunerStudio configuration is now complete. If you were unsuccessful in selecting a COM port above and got a “Failed!” message, you’ll need to revert back to the USB installation instructions at this time and get the USB adapter working. Once working, proceed to the next section of this setup guide. 

Initial Configuration/Software Setup
1) Connect the supplied tuning cable to the ECU and to your PC or USB adapter.
2) Ensure vehicle battery is fully charged

3) Open TunerStudio software, and turn ignition key to the “run” position, DO NOT CRANK VEHICLE AT THIS TIME.  You should hear the fuel pump run for approximately 2 seconds, and then shut off.

4) Verify fuel rail is holding fuel pressure.  This is to ensure no hardware problems exist grounding the injectors (and turning them on).

5) Calibrate TPS and AFR table (wideband).  If non Ford temperature sensors are used, also calibrate them at this time.  See Appendix C for sensor calibration instructions.
6) “Key Cycle.”  This means turn the ignition off, then back to run (not start).

7) Verify all sensors read correctly on TunerStudio dashboard.  Verify TPS reads close to 0 (+/- 1%) when closed, and close to 100% when open.  MAP should read very close to 100 kpa, unless located at high altitude.  If you suspect incorrect MAP reading, check your favorite weather source for a current barometer reading.

8) If all inputs read correctly, it is now time to attempt to crank the engine. Your ECU is shipped with a tuning file that will not fire the injectors so don’t be surprised when it doesn’t try to start. To make sure it doesn’t start, unplug your injector harness. Spin the engine over, and view the tachometer located on the TS display.  You should see a reasonable (between 200 and 400 rpm) cranking RPM, with “synced” displayed in the bottom right hand corner of your screen. Plug your injector harness back in at this time.
9) Now you need to verify that cranking timing is 10 degrees BTDC. Grab your timing light and put it on the #1 spark plug wire. Crank the engine over and point the timing light at the crank pulley to view timing advance. If it is cranking at something other than exactly 10 degrees BTDC, you’ll need to loosen the distributor hold down bolt and rotate the distributor until it reads 10 degrees BTDC when cranking. Tight down the distributor hold down bolt and then verify it is still 10 degrees when cranking.

10) If “sync” and reasonable speed was obtained in the previous step, you are now ready to load your base tune that was provided on the 1GB USB flash drive (In TunerStudio: File > Open Tune and then find the base tune file on the USB drive), and configure for your injectors (In TunerStudio: Basic Setup > Engine Constants > Required Fuel and enter your engine size, number of cylinders, injector flow rate, and Air-Fuel Ratio (14.7 for gasoline). 
11) Now lets set the base tune to match your injector characteristics. (In TunerStudio > Basic Settings > Injector Charateristics > Injector Open Time (ms)), you need to set this value to match the type of injectors you are running. 
For factory 2.3T injectors, or Bosch & Delphi Low Imp, use 1.1. For TFX Low Imp, use 1.2. For the High Imp Siemens Deka 4 Motron injectors we sell, use 0.7.
More complete injector listing and additional details found here: http://stinger-performance.proboards.com/index.cgi?action=display&board=pimp&thread=1476
Also, For larger than 60lb injectors, change the (Basic Settings > Engine Constants) settings to 2 squirts/cycle alternating or 1 simultaneous. Following this step, your engine is ready to run.   
12) Attempt to start the engine.  Your engine will likely run at this point.  Follow tuning guides located at http://stinger-performance.proboards.com/index.cgi?board=pimp. If you have additional questions, please ask them on our forum at the above link. 

13) Once running and before driving, you need to make sure the timing that is commanded on the laptop is the same as the actual timing number at the engine. In TunerStudio, go to (Basic Setup > More Ignition Options > Fixed Advance and change it from "use table" to "fixed timing"). Then make sure "timing for fixed advance” is set to 20. This will lock the commanded timing at 20 degrees. With the engine running, put a timing light on the #1 plug wire and point it at the crank pulley. Verify that timing is at 20 degrees BTDC. If it isn't, rotate the distributor until the timing is 20 degrees BTDC. Tighten up the distributor hold down, verify timing is still 20 degrees, then go into the same location in TunerStudio and put it back to "use table". Verify timing is now advancing in order to match the timing table.
Feature Explanation
The below descriptions are a general description of “optional” features.  Consult MS2 Extra documentation found at www.msextra.com  for more detailed information.

Cooling Fan control:  This feature grounds a relay, which in this case controls one or two cooling fans.  See software settings section for screenshot and explanation of settings.
Table Switching:  Table switching allows two sets of tables (generally fuel, spark, AFR, or boost) tables to be toggled via a switch.  An example would be both a “premium” and “regular” fuel map.
Launch Control:  Allows the use of selectable rev limits when engaged (think drag racing 2-step).  Can also be configured for “flat shifting.”  This feature allows separate launch and shifting rev limits designed to maintain boost during shifts, triggered from one (usually the clutch) input.  Generally the shifting rev limit is set to roughly match the RPM drop between shifts.  

Boost control:  The ECU controls a solenoid that typically bleeds off wastegate pressure.  Can be configured either “open loop” (you manually adjust a solenoid duty cycle to achieve your targets), or “closed loop” (the ECU adjust duty to target a particular boost level).  Both “open” and “closed” loop tables are engine speed and throttle position dependant. This is typically done with an aftermarket boost control solenoid.
Nitrous Control:  The ECU accepts an input (typically your arming switch interrupted through the typical WOT safety switch) that signals you wish to engage the nitrous. The PIMP ECU then becomes your “window switch” triggering your nitrous control relays when your desired engine speed and throttle position targets are reached.  Two stages of nitrous control are available. This requires nitrous solenoids and required wiring of course.
The ECU can also modify the fuel and spark when nitrous is enabled (normally add fuel/retard spark).  There are fuel and spark settings for both nitrous stages.

Appendix A

Jumper Explanation
Depending on your engine configuration, jumpers inside the PiMP ECU case need to be inserted in their proper location. This is so the PiMP knows what type of injectors you are running, how many cylinders the engine has, what kind of fueling strategy will be used, single or dual cooling fans, and whether you will use table switching. We purposely don’t install these prior to shipment and instead include a bag of them so you’ll get comfortable with how this process works. You will need to double check you install the jumpers correctly prior to running the engine. You’ll need a pair of needle nose pliers to install the jumpers and a 5.5mm or 7/32” socket to remove the ecu case cover to access the jumpers.
Injector Jumpers

Injectors:  Your ECU can be directly connected to high impedance injectors, or 4 low impedance injectors.  Low impedance injectors are not supported with greater than 4 cylinders.

4 cylinder low impedance (originally bank fired, e.g. 2.3 Turbo):  Install no injector jumpers.  If jumpers are installed with low impedance injectors, damage to the injectors and ECU may result.

4 cylinder high impedance (originally bank fired, e.g. 2.3 Turbo w/ high imp injectors):  Install shorting jumpers INJ1 and INJ2

8 cylinder high impedance (originally bank fired):  Install shorting jumpers INJ1 and INJ2

8 cylinder high impedance (originally sequentially fired e.g. 5.0 EFI Mustang):  Install shorting jumpers INJ1-8.  See Figure 3.
Ignition Jumpers
While your PIMP ECU can support additional ignition systems with extra hardware, in the “plug and play” configuration only TFI, EDIS, and CDI boxes (MSD, Mallory, etc.) are supported.

TFI- Jumper pullup jumper to 12v.  See Figure 2 for pullup jumper installation
EDIS-Jumper pullup jumper to 5v.

CDI-Do not install pullup jumper.
If an installation kit was purchased with your CDI box, the box can be connected and configured as Ford TFI, but this setup will not allow for a spark cut rev limiter.  See Appendix D for universal installation instructions for CDI ignition.

Fan Jumpers

The 87-88 turbocoupe wiring was chosen for fan outputs.   This means pin 55 for primary fan, and pin 52 for high fan.  Pin 52 is also used as an injector output on a V8, so high fan can not be used for a v8.  See Figure 3 for fan jumpers.  These are connected to the WLED (high pin) and ALED (low fan) outputs of the PIMP ECU.  

Table Switching Jumpers

Table switching can be connected via the DB25 expansion connector, or it can be connected to the OE 87-88 turbocoupe premium fuel selector switch (pin 24 of EEC connector).  To enable table switching, install TBL SW jumper located near the top left of the board to enable table switching.  This will bring table switching out on the DB25 expansion connector.  To connect to the 87-88 Turbo Coupe premium switch, also install the TBL SW jumper located near the EEC connector (see Figure 2).  It should be noted the use of table switching conflicts with the use of nitrous control, so if you wish to run nitrous control, you can not run table switching.
Clutch Input (for Launch/Flatshift/2-step)

The clutch input is triggered by grounding the clutch input pin. This can be done either through the db25 expansion connector, or via the factory EEC neutral input (already connected to the clutch switch) which is EEC pin 30.  If it is desired to connect to the factory neutral input, jumper the CLTCH jumper located near the EEC connector. See Figure 3
Boost Control

Boost control can either be connected through the db25 expansion connector, or via the Turbo Coupe EEC BCS control.  In order to enable boost control, jumper the boost control jumper located just below the TBL SW/N20 jumper. See Figure 1  Additionally, if it is desired to use the factory BCS wiring* jumper the boost control jumper near the EEC connector. See Figure 3
*ECU uses 87-88 Turbo Coupe BCS pin 31.  If vehicle originally came equipped with a P series ECU (83-86 Turbo Coupe, Mustang, any year XR4Ti) and hasn’t been swapped for an LA3, move the pin located at position 32 to position 31 if you want to use PIMP controlled boost control.
Nitrous Control

Nitrous control is supported only via the DB25 expansion connector.  In order to enable the “input” for nitrous control, jumper the TBL SW/N20 IN jumper to N20 IN.  Nitrous output jumpers are located below this jumper, and are labeled N20, with 1 and 2.  The 1 and 2 denote stages.  Jumper 1 for a single stage of nitrous, and both for dual stage.

Figure1
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Figure 3
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Appendix B


ACT/IAT Sensor Installation
For cars not equipped with an air charge temperature sensor from the factory, you’ll need to install one for use with the PiMP. 87-88 Turbo Coupe, dual plug Mustangs/Rangers, and 87-95 5.0 Mustangs came with an ACT sensor. SVO, Turbo GT, 83-86 Turbo Coupe, and Merkur XR4Ti did not come with an ACT. 
The ACT needs to be wired into the factory ECU connector at pin 25 for the signal wire and pin 46 for the ground. Factory ACT sensor equipped cars are already wired this way. For VAM equipped cars that aren’t rewired for an LA3 ECU and already have an ACT*, the easiest way to do this is to wire the ACT through the VAM wiring plug VAT wire (light green/purple stripe in the location shown in the diagram below) which is already in pin location 25 in the factory ECU connector. Then wire the ground side of the ACT to the black VAM wire. Install the ACT sensor in the factory location in the intake manifold or in the intercooler tubing after the intercooler. 
*Note that some people rewire their vehicle to run an LA3 or equivalent ECU (LB2, LB3, 8UA) and never install an ACT sensor. If your car didn’t come with an LA3 or equivalent but was wired for and running one before installation of the PiMP, you’ll need to verify that an ACT sensor was installed. Ultimately you need the ACT wire running to pin 25 at the ECU connector and pin 46 for the ACT ground wire.
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Appendix C


TunerStudio Sensor Calibration
TPS Calibration: With the ignition turned on select (Tools > Calibrate TPS). With throttle closed, click Closed throttle ADC count “Get Current” button. Now press the throttle pedal all the way to the floor and click Full throttle ADC count “Get Current” button. Once the values are set, click close.
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Wideband Sensor Calibration: select (Tools > Calibrate AFR Table) and then select the type of wideband sensor you are using. If you are using a wideband controller that has a programmable volts/afr curve (such as the Innovate LM-1/LC-1) then be sure to select “Custom Linear WB” and enter the values in the table that match the settings your controller is using.
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If you are using any non-Ford sensors (namely ACT/IAT or coolant temp sensors), you’ll need to calibrate them. Select (Tools > Calibrate Thermistor Tables). Most common options are available in the drop down menus. 
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Appendix D


Universal Installation Instructions for CDI Ignition.

Remove spout pill at the TFI. Now connect the ECU side wire to the points trigger wire of CDI box (white for MSD*). Don’t install ignition pullup jumper (leave 5v and 12v jumper locations empty). If you have an MSD tach adapter, do not use it with the PiMP or damage to the PiMP may result.

*Note the diagram below is for MSD ignitions. If using another brand, wire colors may be different so you’ll need to follow the instructions for that particular CDI ignition box. Just be sure to attach the points trigger wire to the spout wire going to the ECU.
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Important Tips, & Reminders

When making changes to your tune, be sure to save the changes (In TunerStudio: File > Save Tune As) and then rename the file something other than the original name. This is so you can revert back to a previous tune if you find the changes you’ve been making have made it run worse, not better. Furthermore, it often helps to name the file for the changes you’ve made so you can look at the tune list and tell what is different compared to other tunes you’ve made. In example would be if your original file name is basetune.msq and you change the rev limiter settings, when you save the file, name it basetune-revlimit.msq or something similar.
Be sure to backup all provided files on your computer, a cd, or other storage media.

Last but not least, don’t change settings in TunerStudio that you don’t understand. Engine damage may result from such activity. If you want, you can hide the advanced features to reduce the temptation to change settings you shouldn’t mess with as a beginner (In TunerStudio: Basic Setup > Basic/Advanced user and select how much you want to limit yourself). You can always change it back to advanced at a later date.
Liability & Restrictions
Stinger Performance and all related parties are not responsible for damages resulting from the use or misuse of the PiMP Engine Management system. Failure to follow instructions provided and/or failure to properly tune your engine may result in engine damage.

Emission controlled cars may not legally use any aftermarket ECU. Stinger Performance and all related parties are not responsible for failed emissions testing or any penalties resulting from such testing.

